This documentation is for Dovecot v2.x, see wiki1 for v1.x documentation.
Differences between revisions 6 and 7
Revision 6 as of 2007-09-29 01:43:00
Size: 2112
Editor: ppp59-167-55-95
Comment:
Revision 7 as of 2007-11-11 16:32:04
Size: 2189
Editor: TimoSirainen
Comment:
Deletions are marked like this. Additions are marked like this.
Line 5: Line 5:
 * Are you using an older version than v1.0? RHEL 5 and ["Debian"] Etch distribute v1.0.rc15, and there has been a LOT of fixes since then. If you have a problem, see if [http://dovecot.org/doc/NEWS NEWS] file mentions anything related to it.  * Are you using an older version than v1.0? RHEL 5 and Debian Etch distribute v1.0.rc15, and there has been a LOT of fixes since then. If you have a problem, see if [http://dovecot.org/doc/NEWS NEWS] file mentions anything related to it. There are also [:PrebuiltBinaries:binary packages] available for newer versions.

Why doesn't Dovecot work?

  • Dovecot always logs an error message if anything goes wrong, so make sure you're looking at the correct log files. Debug messages may be written to a different log file than error messages. See ["Logging"].

  • Try logging in manually by sending IMAP commands. If you're trying with an IMAP client you can't be sure if the problem is with the client's configuration or Dovecot's configuration. See TestInstallation (or TestPop3Installation).

  • Are you using an older version than v1.0? RHEL 5 and Debian Etch distribute v1.0.rc15, and there has been a LOT of fixes since then. If you have a problem, see if [http://dovecot.org/doc/NEWS NEWS] file mentions anything related to it. There are also [:PrebuiltBinaries:binary packages] available for newer versions.

It says password mismatch

If you're using PAM:

  • Make sure that dovecot-auth is running as root (assuming it's using /etc/shadow).

  • PAM errors aren't written to Dovecot's own logs. Usually they go to /var/log/auth.log or something similar.

    • Unfortunately PAM's error messages aren't always all that helpful in figuring out what exactly the problem is.
  • Usually the problem is that you don't have a correctly named file in /etc/pam.d/. See ["PasswordDatabase/PAM"]

For non-PAM set auth_debug_passwords=yes and look at what it says in the logs. If it's trying to use a wrong password scheme, you can change that. See ["Authentication/PasswordSchemes"]

It says Can't load certificate

And the key isn't password protection and you get an error like:

Sep 29 01:33:54 mail dovecot: imap-login: Can't load certificate file /etc/ssl/private/ssl-cert-mail-cacert.pem: error:0906D06C:PEM routines:PEM_read_bio:no start line
Sep 29 01:33:54 mail dovecot: child 27252 (login) returned error 89
Sep 29 01:33:54 mail dovecot: imap-login: Can't load certificate file /etc/ssl/private/ssl-cert-mail-cacert.pem: error:0906D06C:PEM routines:PEM_read_bio:no start line
Sep 29 01:33:54 mail dovecot: child 27253 (login) returned error 89

You've mixed up the ssl_cert_file and ssl_key_file directives in your config file.

None: WhyDoesItNotWork (last edited 2018-09-09 05:36:49 by AkiTuomi)