This documentation is for Dovecot v2.x, see wiki1 for v1.x documentation.
Differences between revisions 1 and 2
Revision 1 as of 2007-03-17 12:36:18
Size: 1092
Editor: TimoSirainen
Comment:
Revision 2 as of 2007-03-19 02:29:14
Size: 1118
Editor: TimoSirainen
Comment:
Deletions are marked like this. Additions are marked like this.
Line 3: Line 3:
 * Make sure you're looking at the correct log files. Debug messages may be in a different log file than error messages. See ["Logging"]  * Make sure you're looking at the correct log files. Debug messages may be written to a different log file than error messages. See ["Logging"].
Line 10: Line 10:
 * Make sure that dovecot-auth is running as root (assuming it's using shadow files).
 * PAM errors aren't logged to Dovecot's own logs. Usually they go to {{{/var/log/auth.log}}} or something similar.
  * Unfortunately PAM's error messages aren't all that helpful always in figuring out what the problem is.
 * Usually the problem is that you don't have correctly named file in {{{/etc/pam.d}}}. See ["PasswordDatabase/PAM"]
 * Make sure that dovecot-auth is running as root (assuming it's using {{{/etc/shadow}}}).
 * PAM errors aren't written to Dovecot's own logs. Usually they go to {{{/var/log/auth.log}}} or something similar.
  * Unfortunately PAM's error messages aren't always all that helpful in figuring out what exactly the problem is.
 * Usually the problem is that you don't have a correctly named file in {{{/etc/pam.d/}}}. See ["PasswordDatabase/PAM"]

Why doesn't Dovecot work?

  • Make sure you're looking at the correct log files. Debug messages may be written to a different log file than error messages. See ["Logging"].
  • Try logging in manually by sending IMAP commands. If you're trying with an IMAP client you can't be sure if the problem is with the client's configuration or Dovecot's configuration. See TestInstallation (or TestPop3Installation).

It says password mismatch

If you're using PAM:

  • Make sure that dovecot-auth is running as root (assuming it's using /etc/shadow).

  • PAM errors aren't written to Dovecot's own logs. Usually they go to /var/log/auth.log or something similar.

    • Unfortunately PAM's error messages aren't always all that helpful in figuring out what exactly the problem is.
  • Usually the problem is that you don't have a correctly named file in /etc/pam.d/. See ["PasswordDatabase/PAM"]

For non-PAM set auth_debug_passwords=yes and look at what it says in the logs. If it's trying to use a wrong password scheme, you can change that. See ["Authentication/PasswordSchemes"]

None: WhyDoesItNotWork (last edited 2018-09-09 05:36:49 by AkiTuomi)