This documentation is for Dovecot v2.x, see wiki1 for v1.x documentation.
Differences between revisions 11 and 12
Revision 11 as of 2010-08-29 05:41:38
Size: 752
Editor: interfaSys
Comment:
Revision 12 as of 2011-09-11 12:02:55
Size: 953
Editor: 78
Comment: Add node about needing Exim >= 4.72
Deletions are marked like this. Additions are marked like this.
Line 34: Line 34:

If you are having problems with this not working ensure that you are using version 4.72 or greater of exim. Previous versions of exim have trouble with the version of the protocol used in Dovecot 2

Exim and Dovecot SASL

Exim v4.64+ users can use Dovecot SASL instead of Cyrus SASL for authenticating SMTP clients.

conf.d/10-master.conf

service auth {
...
#SASL
  unix_listener auth-client {
    mode = 0660
    user = mail
  }
...
}

exim.conf

Create authenticators for Dovecot:

dovecot_login:
  driver = dovecot
  public_name = LOGIN
  server_socket = /var/run/dovecot/auth-client
# setting server_set_id might break several headers in mails sent by authenticated smtp. So be careful.
  server_set_id = $auth1

dovecot_plain:
  driver = dovecot
  public_name = PLAIN
  server_socket = /var/run/dovecot/auth-client
  server_set_id = $auth1

If you are having problems with this not working ensure that you are using version 4.72 or greater of exim. Previous versions of exim have trouble with the version of the protocol used in Dovecot 2

None: HowTo/EximAndDovecotSASL (last edited 2013-11-16 15:18:10 by office)